Problémy podpory XML v PHP5

  • chybějící podpora Unicode ze strany jazyka

  • PHP5 má rozhraní XML kompletně předělána a není kompatibilní s předchozími verzemi

  • v návrhu XML API pro PHP 5.0 bylo opomenuto několik klíčových funkcí, většina z nich je naštěstí opravena v PHP 5.1

  • pro běh ukázkových příkladů je potřeba PHP alespoň ve verzi 5.1